通达信北狼绝谷指标公式

N:=89;
VAR1:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR2:=(CLOSE-MA(CLOSE,26))/MA(CLOSE,21)*100;
VAR3:=(CLOSE-MA(CLOSE,90))/MA(CLOSE,34)*100;
VAR4:=(VAR1+3*VAR2+9*VAR3)/13;
VAR5:=(100-ABS(VAR4));
VAR6:=ABS((COST(40)-CLOSE)/CLOSE*100);
VAR10:=LLV(LOW,10);
VAR13:=HHV(HIGH,25);
M:=EMA((CLOSE-VAR10)/(VAR13-VAR10)*4,4)*25,COLORYELLOW,LINETHICK2;
RSV10:= (HHV(HIGH,11)-CLOSE)/(HHV(HIGH,11)-LLV(LOW,11))*100;
LWR1:100-SMA(RSV10,3,1),COLORRED,LINETHICK0;
LWR2:SMA(LWR1,3,1),COLORWHITE,LINETHICK0;
DRAWBAND(LWR1,RGB(200,0,200),LWR2,RGB(200,200,200));
STICKLINE(LWR1>80 AND CROSS(LWR2,LWR1),100,80,1,0),COLOR00FFFF;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
很准:CROSS(RSI,11)*45,COLOR00FFFF,LINETHICK2;
DRAWTEXT(CROSS(RSI,11),47,'准'),COLOR66FFCC;
AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
绝谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
杀入:IF(CROSS(绝谷,90) AND (DD<40),40,0),COLORFFFF00,LINETHICK2;
DRAWTEXT(CROSS(绝谷,90) AND (DD<40),42,'杀入'),COLOR66FFCC,LINETHICK2;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1),COLORYELLOW;
D:=SMA(K,3,1),COLORWHITE,;
买进:IF(D<25 AND CROSS(K,D) ,30,0),COLORMAGENTA,LINETHICK2;
DRAWTEXT(D<25 AND CROSS(K,D),32,'买进'),COLOR66FFCC,LINETHICK2;
卖出:IF(D>75 AND CROSS(D,K) ,80,100),COLORGREEN,LINETHICK2;
STICKLINE(K>D,K,D,2,0),COLORRED;
STICKLINE(D>K,K,D,2,1),COLOR00FF00;

通达信北狼绝谷指标公式

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:/46805.html