双信号选股公式

选股公式源码


流通:=FINANCE(7)/100000000<=10;
MA181:=MA(CLOSE,181);
FF:=EMA(CLOSE,3);
MA21:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA21);
SS:=EMA(C,3),COLORBLUE,LINETHICK1;
MM:=SS>REF(SS,1) AND REF(SS,1)V5:=MA((LOW+HIGH+CLOSE)/3,5);
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)=REF(C,1);
VAR06:=V5>REF(V5,1) AND REF(V5,1)VAR07:=LOWHHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSVQ:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSVQ,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR04;
买3:=(VAR14 OR VAR15) AND VAR02;
买4:=(VAR02 AND VAR11) OR (VAR04 AND VAR11);
买5:=(金叉 AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=(买1 OR 买2 OR 买3 OR 买4 OR 买5) AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:(XG0 OR XG1) AND CROSS(C,MA181) AND 流通;

选股公式翻译


流通赋值:流通股本(股)/100000000<=10
MA181赋值:收盘价的181日简单移动平均
FF赋值:收盘价的3日指数移动平均
MA21赋值:收盘价的21日指数移动平均
TTJ赋值:FF上穿MA21
SS赋值:收盘价的3日指数移动平均,画蓝色,线宽为1
MM赋值:SS>1日前的SS AND 1日前的SS<2日前的SS
V5赋值:(最低价+最高价+收盘价)/3的5日简单移动平均
VAR02赋值:收盘价=4日内收盘价的最高值 AND 1日前的收盘价=4日内收盘价的最低值
VAR04赋值:1日前的收盘价=4日内收盘价的最低值 AND 收盘价>=2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价<=3日前的收盘价 AND 2日前的收盘价<4日前的收盘价 AND 收盘价>=1日前的收盘价
VAR06赋值:V5>1日前的V5 AND 1日前的V5<2日前的V5
VAR07赋值:最低价<13日内V5的最高值 AND 最高价>13日内V5的最高值 AND 收盘价>1日前的收盘价 AND 收阳线
VAR08赋值:VAR07 AND 统计2日中满足VAR06的天数
VAR09赋值:100*收盘价-1日前的收盘价的6日指数移动平均的6日指数移动平均/收盘价-1日前的收盘价的绝对值的6日指数移动平均的6日指数移动平均
VAR10赋值:收盘价的13日简单移动平均的13日指数移动平均
VAR11赋值:(2日内VAR09的最低值=7日内VAR09的最低值ANDCOUNT(VAR09<0,2)ANDCROSS(VAR09,VAR09的2日简单移动平均))=1的5日过滤

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109927.html