牛顶底选股公式

选股公式源码


多方能量:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1),;
空方能量:=EMA(MA(多方能量,5),7);
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50;
AA:= (EMA(VAR1,3))*2;
BB:=MA(AA,3);
VAR2:=8,;
{淘金牛妖}
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),;
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),;
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),;
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),;
牛量:=中期=100 OR 中长期=100 OR 长期=100;
能量:=短期=100 OR 中期=100 OR 中长期=100 OR 长期=100;
能量走势:=(多方能量-空方能量)+50;
强势1:=CROSS(能量走势,60) AND REF(能量走势,1)<60;
强势2:=CROSS(AA,60) AND REF(AA,1)<60;
强势:=强势1 AND 强势2;
能量角度:=ATAN((能量走势/REF(能量走势,1)-1)*100)*180/3.1416;
股价角度:=ATAN((AA/REF(AA,1)-1)*100)*180/3.1416;
去除ST:=EXIST((C/REF(C,1)-1)*100>5.6,60);
去除停牌:=DYNAINFO(4)>0; {通达信:今开大于零}
去除高价:=DYNAINFO(7)<40; {最新价小于40元}
去除大盘股:=CAPITAL/1000000<10; {流通盘为10亿以下}
牛量 AND 强势 AND 能量角度>80 AND 股价角度>80 AND 去除ST AND 去除停牌 AND 去除高价 AND 去除大盘股 ;

选股公式翻译


多方能量赋值:7*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均-3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均的3日[1日权重]移动平均-(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均的3日[1日权重]移动平均的2日[1日权重]移动平均,
空方能量赋值:多方能量的5日简单移动平均的7日指数移动平均
VAR1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*50
AA赋值: (VAR1的3日指数移动平均)*2
BB赋值:AA的3日简单移动平均
VAR2赋值:8,
短期赋值:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值),
中期赋值:100*(收盘价-10日内最低价的最低值)/(10日内收盘价的最高值-10日内最低价的最低值),
中长期赋值:100*(收盘价-20日内最低价的最低值)/(20日内收盘价的最高值-20日内最低价的最低值),
长期赋值:100*(收盘价-30日内最低价的最低值)/(30日内收盘价的最高值-30日内最低价的最低值),
牛量赋值:中期=100 OR 中长期=100 OR 长期=100
能量赋值:短期=100 OR 中期=100 OR 中长期=100 OR 长期=100
能量走势赋值:(多方能量-空方能量)+50
强势1赋值:能量走势上穿60 AND 1日前的能量走势

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109924.html