量柱选股公式

选股公式源码


X_1:=VOL/REF(VOL,1);
X_2:=VOL/REF(LLV(VOL,100),1);
X_3:=VOL/REF(HHV(VOL,100),1);
X_4:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_5:=(CLOSE-OPEN)/OPEN*100;
X_6:=(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_7:=VOL/REF(VOL,1)>1.95 AND VOL/REF(VOL,1)<2.05 AND CLOSE>OPEN;
X_8:=VOL/REF(VOL,1)<0.55 AND CLOSELOW;
X_9:=OPEN/CLOSE>=1.04 OR (REF(CLOSE,1)/CLOSE>=1.03 AND
CLOSEIF(REF(X_4>1.095,1),VOL/REF(VOL,1)<=1.1,VOL/MA(VOL,60)<=2/3 OR
VOL/REF(VOL,1)<=1.15 OR VOLX_10:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.03 AND CLOSE>OPEN OR
(CLOSE-OPEN)/OPEN>=0.04 AND (VOL<=MA(VOL,60) OR
VOL/REF(VOL,1)<=1.2 OR VOLIF(REF(HIGH=LOW,1),VOL/REF(VOL,1)<16,VOL/REF(VOL,1)<6) AND
HIGH>LOW;
X_11:=REF(X_4>0 AND CLOSE>OPEN,2) AND REF(X_4>0 AND
CLOSE>OPEN,1) AND X_4>0 AND CLOSE>OPEN AND
REF(VOL,1)/REF(VOL,2)>1.05 AND VOL/REF(VOL,1)>1.02 AND
CLOSE/REF(CLOSE,1)>1.07;
X_12:=REF(X_3>1,1) AND VOL/REF(VOL,1)>1.2 AND CLOSE>REF(HHV(CLOSE,21),1);
X_13:=REF(X_10,2) AND REF(X_3>1,1) AND X_3>1;
X_14:=REF(CLOSE=REF(HHV(MAX(CLOSE,OPEN),21),1) AND REF(VOL,1)/REF(VOL,2)>0.85 AND X_10;
X_15:=REF(X_10,1) AND X_10 AND VOL/REF(VOL,1)>1.2;
X_16:=REF(X_10,2) AND REF(X_10,1) AND X_10 AND VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2);
X_17:=X_10 AND NOT(REF(X_3>=1,1) AND REF(CLOSENOT(X_3>1) AND NOT(X_11) AND NOT(REF(X_12,1) AND
VOL/REF(VOL,1)>0.85) AND NOT(X_14) AND NOT(X_15) AND NOT(X_16);
X_18:=ABS(X_4)<=3 AND ABS(X_5)<=2;
X_19:=REF(X_9,1) AND X_18 OR (REF(X_9,2) AND REF(X_18,1) AND X_18) OR
(REF(X_9,3) AND REF(X_18,2) AND REF(X_18,1) AND X_18) OR (REF(X_9,4) AND
REF(X_18,3) AND REF(X_18,2) AND REF(X_18,1) AND X_18);
X_20:=CLOSE>OPEN AND X_4<(-4);
X_21:=CLOSEX_22:=REF(CLOSE(REF(CLOSE>=OPEN,1) AND REF(CLOSE,1)(CLOSE=OPEN AND CLOSEAND CLOSEVOLX_23:=REF(CLOSE<=OPEN,3) AND REF(CLOSE<=OPEN,2) AND
REF(CLOSE<=OPEN,1) AND CLOSE<=OPEN AND CLOSE<=REF(CLOSE,1) AND
REF(CLOSE,1)<=REF(CLOSE,2) AND REF(CLOSE,2)<=REF(CLOSE,3);
X_24:=COUNT(CLOSE<=OPEN AND CLOSE=3 AND CLOSEX_25:=REF(X_9,1) AND REF(ABS(X_5),1)>2 AND CLOSE>OPEN AND CLOSE>REF((CLOSE+OPEN)/2,1) AND VOL/REF(VOL,1)<2.6;
X_26:=REF(X_19,1) AND X_17;
X_27:=REF(X_9,1) AND X_17;
X_28:=REF(X_20,1) OR REF(X_20,2) AND (X_17 OR (CLOSE>REF(CLOSE,1) AND
VOL>REF(VOL,1) AND VOL/REF(VOL,1)<6)) AND CLOSE>OPEN AND
(X_4>3 OR X_5>4);
X_29:=REF(X_19,1) AND CLOSE>OPEN AND X_4>3 AND VOL>REF(VOL,1);
X_30:=REF(X_22,1) AND (X_17 OR (CLOSE>REF(OPEN,1) AND VOL>REF(VOL,1) AND VOL/REF(VOL,1)<2.6) AND X_4>3);
X_31:=REF(X_9,2) AND REF(X_19,1) AND CLOSE>=OPEN AND CLOSE>REF(MAX(CLOSE,OPEN),1);

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109921.html