神龙启动选股公式

选股公式源码


白龙:= MA(CLOSE,125),;
黄龙:= 白龙+2*STD(CLOSE,170);
紫龙:= 白龙-2*STD(CLOSE,145);
青龙:=SAR(125,1,7){, LINESTICK},;
VAR2:=HHV(HIGH,70);
VAR3:=HHV(HIGH,20);
红龙:= VAR2*0.83,;
蓝龙:= VAR3*0.91,;
CRSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
CK0:=SMA(CRSV,3,1);
CK:=CK0;CD:=SMA(CK0,2,1);
CJ1:=(3*CK0-2*CD),;
CJ2:=MA(CJ1,2),;
去除ST:=IF(NAMELIKE('ST'),0,1) AND IF(NAMELIKE('*ST'),0,1);
去除停牌:=DYNAINFO(4)>0;
XG:=去除ST AND 去除停牌;
X1:= CROSS(蓝龙,红龙) OR (CROSS(蓝龙,青龙) AND 蓝龙>REF(蓝龙,1));
工作线:=MA("KDJ.J#WEEK"(9,3,3) ,5),;
工作:=工作线>5;
前引线:="PAVE.CV",;
引导线:="PAVE.MCV",;
主导线:="PAVE.DIFF",;
主线:=ABS(主导线-前引线);
AA:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
能量:=SMA(AA,32,8),;
BB:=IF(能量>REF(能量,1),能量-能量*1/100,能量+能量*1/100);
趋势线:=SMA(BB,19,6),;
差值:=能量-趋势线,;
主线A:=主线X2:X1 AND CAPITAL<20000000 AND C<=15 AND 黄龙>REF(黄龙,1) AND
C>青龙 AND C>蓝龙 AND 白龙>REF(白龙,1) AND 紫龙>REF(紫龙,1) AND
C>REF(C,1)
AND 蓝龙>青龙 AND XG AND CJ1>REF(CJ1,1) AND CJ1>CJ2 AND 工作 AND
工作线>REF(工作线,1) AND 青龙>REF(青龙,1) AND (主线<=20 OR 主线A) AND
趋势线>=20 AND 趋势线>REF(趋势线,1);

选股公式翻译


白龙赋值: 收盘价的125日简单移动平均,
黄龙赋值: 白龙+2*收盘价的170日估算标准差
紫龙赋值: 白龙-2*收盘价的145日估算标准差
青龙赋值:步长为1极限值为7的125日抛物转向,
VAR2赋值:70日内最高价的最高值
VAR3赋值:20日内最高价的最高值
红龙赋值: VAR2*0.83,
蓝龙赋值: VAR3*0.91,
CRSV赋值:(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100
CK0赋值:CRSV的3日[1日权重]移动平均
CK赋值:CK0
CD赋值:CK0的2日[1日权重]移动平均
CJ1赋值:(3*CK0-2*CD),
CJ2赋值:CJ1的2日简单移动平均,
去除ST赋值:如果模糊匹配品种名称,返回0,否则返回1 AND 如果模糊匹配品种名称,返回0,否则返回1
去除停牌赋值:开盘价>0
XG赋值:去除ST AND 去除停牌
X1赋值: 蓝龙上穿红龙 OR (蓝龙上穿青龙 AND 蓝龙>1日前的蓝龙)
工作线赋值:"KDJ的J[取周线数据]"(9,3,3)的5日简单移动平均,
工作赋值:工作线>5
前引线赋值:"强筹码引力的CV",
引导线赋值:"强筹码引力的MCV",
主导线赋值:"强筹码引力的DIFF",
主线赋值:主导线-前引线的绝对值
AA赋值:(收盘价-43日内最低价的最低值)/(43日内最高价的最高值-43日内最低价的最低值)*100
能量赋值:AA的32日[8日权重]移动平均,
BB赋值:如果能量>1日前的能量,返回能量-能量*1/100,否则返回能量+能量*1/100
趋势线赋值:BB的19日[6日权重]移动平均,

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109900.html