抓强牛选股公式

选股公式源码


XA_1:=MA(CLOSE,5);
XA_2:=MA(CLOSE,10);
XA_3:=IF(CLOSE>=TDXWAVE.NOTEXTWAVE AND (CLOSE>XA_1 OR CLOSE>XA_2),70,0);
XA_4:=IF(CLOSE>TDXWAVE.NOTEXTWAVE AND (CLOSEXA_5:=IF(CLOSEXA_6:=XA_3+XA_4+XA_5;
XA_7:=IF(CLOSE>XA_1 AND XA_1>XA_2,70,0);
XA_8:=IF(CLOSEXA_9:=XA_7+XA_8;
XA_10:=IF(XA_9=0,50,0);
XA_11:=XA_7+XA_8+XA_10;
XA_12:=XA_6*0.5+XA_11*0.5;
XA_13:=10;
XA_14:=NOT(NAMELIKE(1) OR NAMELIKE(2));
XA_15:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOWXA_16:=BARSCOUNT(CLOSE)>=30;
XA_17:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW=HIGH)*3;
XA_18:=CLOSE>OPEN*1.027;
XA_19:=(HIGH>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSEXA_20:=XA_13+XA_15+XA_17+XA_19;
XA_21:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_22:=XA_20*XA_21;
XA_23:=(EMA(CLOSE,12)/EMA(CLOSE,26)-1)*1000;
XA_24:=DYNAINFO(4)>0;
XA_25:=EMA(XA_23,5);
XA_26:=XA_25-REF(XA_25,1);
XA_27:=(EMA(INDEXC,12)/EMA(INDEXC,26)-1)*1000;
XA_28:=EMA(XA_27,5);
XA_29:=XA_28-REF(XA_28,1);
XA_30:=(XA_26-XA_29)*50;
XA_31:=XA_22+XA_30+XA_12;
XA_32:=XA_31>470;
XA_33:=BARSLAST(XA_32);
XA_36:=BETWEEN(XA_33,0,2);
XA_37:=MA(CLOSE,5);
XA_38:=MA(CLOSE,10);
XA_39:=XA_38XA_40:=REF(XA_36,1)>0 AND XA_39;
XA_41:=REF(XA_40,1) AND XA_14 AND XA_16 AND XA_18 AND XA_24;
XG:FILTER(XA_41,20);

选股公式翻译


XA_1赋值:收盘价的5日简单移动平均
XA_2赋值:收盘价的10日简单移动平均
XA_3赋值:如果收盘价>=通达信趋势浪的NOTEXTWAVEAND(收盘价>XA_1ORCLOSE>XA_2),返回70,否则返回0
XA_4赋值:如果收盘价>通达信趋势浪的NOTEXTWAVEAND(收盘价XA_5赋值:如果收盘价<通达信趋势浪的NOTEXTWAVE,返回30,否则返回0
XA_6赋值:XA_3+XA_4+XA_5
XA_7赋值:如果收盘价>XA_1ANDXA_1>XA_2,返回70,否则返回0
XA_8赋值:如果收盘价XA_9赋值:XA_7+XA_8
XA_10赋值:如果XA_9=0,返回50,否则返回0
XA_11赋值:XA_7+XA_8+XA_10
XA_12赋值:XA_6*0.5+XA_11*0.5
XA_13赋值:10
XA_14赋值:取反
XA_15赋值:(收盘价>=计算涨停价 AND 最低价<最高价)*8
XA_16赋值:收盘价的有效数据周期数>=30
XA_17赋值:(收盘价>=计算涨停价 AND 最低价=最高价)*3
XA_18赋值:收盘价>开盘价*1.027
XA_19赋值:(最高价>=计算涨停价 AND 收盘价<最高价)*2
XA_20赋值:XA_13+XA_15+XA_17+XA_19
XA_21赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
XA_22赋值:XA_20*XA_21
XA_23赋值:(收盘价的12日指数移动平均/收盘价的26日指数移动平均-1)*1000
XA_24赋值:开盘价>0
XA_25赋值:XA_23的5日指数移动平均
XA_26赋值:XA_25-1日前的XA_25
XA_27赋值:(大盘的收盘价的12日指数移动平均/大盘的收盘价的26日指数移动平均-1)*1000
XA_28赋值:XA_27的5日指数移动平均

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109898.html