超牛龙头选股公式

选股公式源码


涨跌:=REF(C,1);
涨停:=IF(((((C - 涨跌) * 100) / 涨跌) >= (10 - ((0.01 * 100) / 涨跌))),1,0);
DIF:=(EMA(C,12) - EMA(C,26));
DEA:=EMA(DIF,9);
MACD:=((DIF - DEA) * 2);
VAR2:=(CLOSE * VOL);
VAR3:=EMA((((((EMA(VAR2,3) / EMA(VOL,3)) + (EMA(VAR2,6) / EMA(VOL,6))) +
(EMA(VAR2,12) / EMA(VOL,12))) + (EMA(VAR2,24) / EMA(VOL,24))) / 4),13);
VAR4:=EMA(CLOSE,9);
飞狐线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 20) / 100));
强势线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 6) / 100));
支撑线:=((((MA(CLOSE,3) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);
压力线:=EMA((VAR4 * 1.14),5);
盈损线:=(LLV(REF(LOW,1),2) + ((HHV(REF(HIGH,1),2) - LLV(REF(LOW,1),2)) / 2));
QD:=(((C > 强势线) AND (C > 支撑线)) AND (C > 盈损线));
小妖:=((COUNT(QD,10) = 1) AND QD);
XYJJ:=BARSLAST(小妖);
JS:=CROSS(C,压力线);
妖狐:=((COUNT(JS,XYJJ) <= 1) AND JS);
HX1:=((REF(妖狐,1) AND (O > 压力线)) AND (C > 压力线));
HX2:=((REF(妖狐,1) AND CROSS(C,飞狐线)) AND (C > 压力线));
狐仙前世:=(小妖 AND 妖狐);
狐仙金身:=(HX1 OR HX2);
妖狐王:=((((REF(涨停,1) AND (O > 压力线)) AND (O > REF(H,1))) AND (REF(H,1) < REF(压力线,1))) AND (L >= 压力线));
((狐仙前世 OR 狐仙金身) OR 妖狐王);

选股公式翻译


涨跌赋值:1日前的收盘价
涨停赋值:如果((((收盘价-涨跌)*100)/涨跌)>=(10-((0.01*100)/涨跌))),返回1,否则返回0
DIF赋值:(收盘价的12日指数移动平均 - 收盘价的26日指数移动平均)
DEA赋值:DIF的9日指数移动平均
MACD赋值:((DIF - DEA) * 2)
VAR2赋值:(收盘价 * 成交量(手))
VAR3赋值:(((((VAR2的3日指数移动平均/成交量(手)的3日指数移动平均)+(VAR2的6日指数移动平均/成交量(手)的6日指数移动平均))+(VAR2的12日指数移动平均/成交量(手)的12日指数移动平均))+(VAR2的24日指数移动平均/成交量(手)的24日指数移动平均))/4)的13日指数移动平均
VAR4赋值:收盘价的9日指数移动平均
飞狐线赋值:(收盘价的25日简单移动平均 + ((收盘价的25日简单移动平均 * 20) / 100))
强势线赋值:(收盘价的25日简单移动平均 + ((收盘价的25日简单移动平均 * 6) / 100))
支撑线赋值:((((收盘价的3日简单移动平均 + 收盘价的6日简单移动平均) + 收盘价的12日简单移动平均) + 收盘价的24日简单移动平均) / 4)
压力线赋值:(VAR4*1.14)的5日指数移动平均
盈损线赋值:(2日内1日前的最低价的最低值 + ((2日内1日前的最高价的最高值 - 2日内1日前的最低价的最低值) / 2))
QD赋值:(((收盘价 > 强势线) AND (收盘价 > 支撑线)) AND (收盘价 > 盈损线))
小妖赋值:((统计10日中满足QD的天数 = 1) AND QD)
XYJJ赋值:上次小妖距今天数
JS赋值:收盘价上穿压力线
妖狐赋值:((统计XYJJ日中满足JS的天数 <= 1) AND JS)
HX1赋值:((1日前的妖狐 AND (开盘价 > 压力线)) AND (收盘价 > 压力线))

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109883.html