上升三法选股公式

选股公式源码


C1:=C*1.01;
O1:=O*0.99;
A1:=REF(C,3+1)-REF(O,3+1)>3;
A2:=RANGE(HHV(C,3),O1,C1) AND RANGE(HHV(O,3),O1,C1);
A3:=RANGE(LLV(C,3),O1,C1) AND RANGE(LLV(O,3),O1,C1);
A4:=RANGE(REF(O,3+1),O1,C1);
A5:=COUNT(ABS(C-O)<0.5,3+1)=3;
B1:=(REF(C,4+1)-REF(O,4+1))/REF(O,4+1)*100>2;
B2:=RANGE(HHV(C,4),O1,C1) AND RANGE(HHV(O,4),O1,C1);
B3:=RANGE(LLV(C,4),O1,C1) AND RANGE(LLV(O,4),O1,C1);
B4:=RANGE(REF(O,4+1),O1,C1);
B5:=COUNT(ABS(C-O)<0.5,4+1)=4;
E1:=(REF(C,5+1)-REF(O,5+1))/REF(O,5+1)*100>2;
E2:=RANGE(HHV(C,5),O1,C1) AND RANGE(HHV(O,5),O1,C1);
E3:=RANGE(LLV(C,5),O1,C1) AND RANGE(LLV(O,5),O1,C1);
E4:=RANGE(REF(O,5+1),O1,C1);
E5:=COUNT(ABS(C-O)<0.5,5+1)=5;
F1:=(REF(C,6+1)-REF(O,6+1))/REF(O,6+1)*100>2;
F2:=RANGE(HHV(C,6),O1,C1) AND RANGE(HHV(O,6),O1,C1);
F3:=RANGE(LLV(C,6),O1,C1) AND RANGE(LLV(O,6),O1,C1);
F4:=RANGE(REF(O,6+1),O1,C1);
F5:=COUNT(ABS(C-O)<0.5,6+1)=6;
T1:=(C-O)/O*100>3;
T2:=(A1 AND A2 AND A3 AND A4 AND A5) OR (B1 AND B2 AND B3 AND B4 AND B5)
OR (E1 AND E2 AND E3 AND E4 AND E5) OR (F1 AND F2 AND F3 AND F4 AND
F5);
T1 AND T2;

选股公式翻译


C1赋值:收盘价*1.01
O1赋值:开盘价*0.99
A1赋值:3+1日前的收盘价-3+1日前的开盘价>3
A2赋值:3日内收盘价的最高值位于O1和C1之间 AND 3日内开盘价的最高值位于O1和C1之间
A3赋值:3日内收盘价的最低值位于O1和C1之间 AND 3日内开盘价的最低值位于O1和C1之间
A4赋值:3+1日前的开盘价位于O1和C1之间
A5赋值:统计3+1日中满足收盘价-开盘价的绝对值<0.5的天数=3
B1赋值:(4+1日前的收盘价-4+1日前的开盘价)/4+1日前的开盘价*100>2
B2赋值:4日内收盘价的最高值位于O1和C1之间 AND 4日内开盘价的最高值位于O1和C1之间
B3赋值:4日内收盘价的最低值位于O1和C1之间 AND 4日内开盘价的最低值位于O1和C1之间
B4赋值:4+1日前的开盘价位于O1和C1之间
B5赋值:统计4+1日中满足收盘价-开盘价的绝对值<0.5的天数=4
E1赋值:(5+1日前的收盘价-5+1日前的开盘价)/5+1日前的开盘价*100>2
E2赋值:5日内收盘价的最高值位于O1和C1之间 AND 5日内开盘价的最高值位于O1和C1之间
E3赋值:5日内收盘价的最低值位于O1和C1之间 AND 5日内开盘价的最低值位于O1和C1之间
E4赋值:5+1日前的开盘价位于O1和C1之间
E5赋值:统计5+1日中满足收盘价-开盘价的绝对值<0.5的天数=5
F1赋值:(6+1日前的收盘价-6+1日前的开盘价)/6+1日前的开盘价*100>2
F2赋值:6日内收盘价的最高值位于O1和C1之间 AND 6日内开盘价的最高值位于O1和C1之间
F3赋值:6日内收盘价的最低值位于O1和C1之间 AND 6日内开盘价的最低值位于O1和C1之间
F4赋值:6+1日前的开盘价位于O1和C1之间
F5赋值:统计6+1日中满足收盘价-开盘价的绝对值<0.5的天数=6
T1赋值:(收盘价-开盘价)/开盘价*100>3
T2赋值:(A1 AND A2 AND A3 AND A4 AND A5) OR (B1 AND B2 AND B3 AND B4 AND B5) OR (E1 AND E2 AND E3 AND E4 AND E5) OR (F1 AND F2 AND F3 AND F4 AND F5)

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/109879.html