优股必杀选股公式

选股公式源码


N:=3;
VAR1:=(C-EMA(C,6))/EMA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
MCD:=EMA(EMA(VAR1,3),N)*2;
VAR5:=EMA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
KX:=MEMA(VAR4,N);
DX:=MEMA(KX,3);
VAR6:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR7:=VAR6REF(MCD,1) AND DX>REF(DX,1) AND V>REF(V,1) AND C>O*1.011;
VAR8:=LLV(VAR5,3)VAR9:=KX>DX AND DX<7;
必杀②:IF(VAR7 AND VAR8 AND VAR9,1,0),;

选股公式翻译


N赋值:3
VAR1赋值:(收盘价-收盘价的6日指数移动平均)/收盘价的6日指数移动平均*100
VAR2赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
VAR3赋值:(收盘价-收盘价的32日简单移动平均)/收盘价的32日简单移动平均*100
VAR4赋值:(VAR1+VAR2+VAR3)/3
MCD赋值:VAR1的3日指数移动平均的N日指数移动平均*2
VAR5赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日指数移动平均-20
KX赋值:VAR4的N日平滑移动平均
DX赋值:KX的3日平滑移动平均
VAR6赋值:100-3*(收盘价-75日内收盘价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内收盘价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR7赋值:VAR6<1日前的VAR6 AND MCD>1日前的MCD AND DX>1日前的DX AND 成交量(手)>1日前的成交量(手) AND 收盘价>开盘价*1.011
VAR8赋值:3日内VAR5的最低值VAR9赋值:KX>DX AND DX<7
输出必杀②:如果VAR7ANDVAR8ANDVAR9,返回1,否则返回0,

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.bbizhi.com/108025.html